Source:  Twitter logo

I want to migrate my project to server-side render to make good SEO, I bit this error for three hours when I run the app. What is the problem I see anything resolve it please how can I fix this,I deleted node_module and package.lock and restart the problem is always there

E:\reactjs\decirshop\node_modules\webpack-cli\bin\cli.js:93
                                throw err;
                                ^

Error: Cannot find module 'webpack/lib/rules/BasicEffectRulePlugin'
    at Function.Module._resolveFilename (internal/modules/cjs/loader.js:580:15)
    at Function.Module._load (internal/modules/cjs/loader.js:506:25)
    at Module.require (internal/modules/cjs/loader.js:636:17)
    at require (E:\reactjs\decirshop\node_modules\v8-compile-cache\v8-compile-cache.js:161:20)
    at Object.<anonymous> (E:\reactjs\decirshop\node_modules\vue-loader-plugin\index.js:4:31)
    at Module._compile (E:\reactjs\decirshop\node_modules\v8-compile-cache\v8-compile-cache.js:194:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:699:10)
    at Module.load (internal/modules/cjs/loader.js:598:32)
    at tryModuleLoad (internal/modules/cjs/loader.js:537:12)
    at Function.Module._load (internal/modules/cjs/loader.js:529:3)
    at Module.require (internal/modules/cjs/loader.js:636:17)
    at require (E:\reactjs\decirshop\node_modules\v8-compile-cache\v8-compile-cache.js:161:20)
    at Object.<anonymous> (E:\reactjs\decirshop\webpack.config.js:6:25)
    at Module._compile (E:\reactjs\decirshop\node_modules\v8-compile-cache\v8-compile-cache.js:194:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:699:10)

Here is my package.json How can I fix this issues

{
  "name": "decirshop",
  "version": "1.0.0",
  "description": "",
  "main": "webpack.config.js",
  "dependencies": {
    "@babel/plugin-proposal-class-properties": "^7.10.4",
    "@fortawesome/fontawesome-svg-core": "^1.2.30",
    "@fortawesome/free-brands-svg-icons": "^5.14.0",
    "@fortawesome/free-solid-svg-icons": "^5.14.0",
    "@fortawesome/react-fontawesome": "^0.1.11",
    "axios": "^0.19.2",
    "bcryptjs": "^2.4.3",
    "body-parser": "^1.19.0",
    "cookie-session": "^1.4.0",
    "cors": "^2.8.5",
    "country-list": "^2.2.0",
    "express": "^4.17.1",
    "express-session": "^1.17.1",
    "form-data": "^3.0.0",
    "framer-motion": "^2.1.0",
    "fs": "0.0.1-security",
    "jquery": "^3.5.1",
    "multer": "^1.4.2",
    "mysql": "^2.18.1",
    "nodemailer": "^6.4.10",
    "react": "^16.13.1",
    "react-dom": "^16.13.1",
    "react-helmet": "^6.1.0",
    "react-image-file-resizer": "^0.3.1",
    "react-paypal-button-v2": "^2.6.2",
    "react-redux": "^7.2.0",
    "react-responsive": "^8.1.0",
    "react-router-dom": "^5.2.0",
    "react-select": "^3.1.0",
    "react-select-country-list": "^2.2.1",
    "react-stripe-checkout": "^2.6.3",
    "redux": "^4.0.5",
    "redux-persist": "^6.0.0",
    "sendmail": "^1.6.1",
    "serve": "^11.3.2",
    "socket.io-client": "^2.3.0"
  },
  "devDependencies": {
    "@babel/core": "7.10.5",
    "@babel/preset-env": "7.10.4",
    "@babel/preset-react": "7.10.4",
    "babel-loader": "8.1.0",
    "concurrently": "5.2.0",
    "css-loader": "^3.6.0",
    "file-loader": "^6.0.0",
    "mini-css-extract-plugin": "^0.9.0",
    "nodemon": "2.0.4",
    "style-loader": "^1.2.1",
    "url-loader": "^4.1.0",
    "vue-loader-plugin": "^1.3.0",
    "webpack": "^4.43.0",
    "webpack-cli": "3.3.12",
    "webpack-node-externals": "^2.5.0"
  },
  "scripts": {
    "test": "echo \"Error: no test specified\" && exit 1",
    "dev": "webpack && concurrently \"webpack --watch\" \"nodemon dist\""
  },
  "author": "",
  "license": "ISC"
}

Try with npm update vue-loader

55 users liked answer #0dislike answer #055
Mr. Czubanns profile pic
Mr. Czubanns

I solved this by updating vue loader. you can use the following command to update vue loader

npm update vue-loader
13 users liked answer #1dislike answer #113
Kosindu Buddhika profile pic
Kosindu Buddhika

I am a Laravel user.

npm i vue-loader

updated Vue-loader from 15.9.6 to 15.9.8 fixed this for me using Laravel 7.30.4 and Vue 2.6.12

    "vue": "^2.6.12",
    "vue-loader": "^15.9.8",
5 users liked answer #2dislike answer #25
odionk profile pic
odionk

I fix it so by remove vue-loader-pluginand install vue-loader follow this link https://vue-loader.vuejs.org/migrating.html#notable-breaking-changes

2 users liked answer #3dislike answer #32
MOUTAIROU Bastou Abdel profile pic
MOUTAIROU Bastou Abdel

I solved this error with

npm install vue-loader@latest
2 users liked answer #4dislike answer #42
ُSeyed Hossein Hosseini Taheri profile pic
ُSeyed Hossein Hosseini Taheri

I solved this by updating vue loader. you can use the following command to update vue loader

npm update vue-loader

2 users liked answer #5dislike answer #52
KowsharAhmed profile pic
KowsharAhmed

you can reinstall webpack to webpack@5.36.2

0 users liked answer #6dislike answer #60
Kenedy Nopriansyah profile pic
Kenedy Nopriansyah

Copyright © 2022 QueryThreads

All content on Query Threads is licensed under the Creative Commons Attribution-ShareAlike 3.0 license (CC BY-SA 3.0).