Source:  Twitter logo

Angular version 9.2.0

When I import the MatToolbarModule in a module and use it in the html template, then I get the following error message:

This likely means that the library (@angular/material/toolbar) which declares MatToolbarModule has not been processed correctly by ngcc, or is not compatible with Angular Ivy. Check if a newer version of the library is available, and update if so. Also consider checking with the library's authors to see if the library is expected to be compatible with Ivy.

8 export declare class MatToolbarModule {
                       ~~~~~~~~~~~~~~~~
src/app/angular-material.module.ts:53:14 - error NG6002: Appears in the NgModule.imports of ComponentsModule, but itself has errors

Does anyone face the same issue?

Add below specific configuration in package.json and npm install.

{
  "scripts": {
    "postinstall": "ngcc"
  }
}

Reference: https://angular.io/guide/ivy#speeding-up-ngcc-compilation

90 users liked answer #0dislike answer #090
Rakesh profile pic
Rakesh

I had the same problem before, its because you modify your app.module.ts file while the server is running. Try to stop it and then run it again using the ng servecommand.

85 users liked answer #1dislike answer #185
Ramzi Bouchair profile pic
Ramzi Bouchair

This used to happen to me whenever I imported 'MatToolbar' 'MatDialog' instead of 'MatToolbarModule' or 'MatDialogModule'.

59 users liked answer #2dislike answer #259
ChrisOdney profile pic
ChrisOdney

So I was just having a similar issue, and I was able to fix it by rearranging my import modules.

In my case, I was calling LoadingBarRouterModule before the main module LoadingBarModule. Check to see if you are loading the MatToolbarModule module before another required module and move it below that.

4 users liked answer #3dislike answer #34
Asitha De Silva profile pic
Asitha De Silva

I faced similar problem with MatDatePicker. The problem was that I had imported MatDatePicker instead of importing MatDatePickerModule in the app.module.ts file.

So, check that you have imported MODULE not Component in your module file.

4 users liked answer #4dislike answer #44
GAURAV JOSHI profile pic
GAURAV JOSHI

I found an error in imports section, i've added unexisting item.

import { MatMenuItem } from '@angular/material/menu';

and MatMenut item doesn't exist, i changed in MatMenuModule and after works

1 users liked answer #5dislike answer #51
iugs88 profile pic
iugs88

Maybe the selected answer could not be the correct one because you may want bundle the dependency when you are building the application.

From https://angular.io/guide/ivy#speeding-up-ngcc-compilation

In version 9, the server builder which is used for App shell and Angular Universal has the bundleDependencies option enabled by default. If you opt-out of bundling dependencies you will need to run the standalone Angular compatibility compiler (ngcc).

I'm opting of restarting the server everytime i'm adding a material component into AppModule. But if i'm wrong, please let me know.

1 users liked answer #6dislike answer #61
Andres Camilo Sierra Hormiga profile pic
Andres Camilo Sierra Hormiga

I solved it by removing the node_modules and reinstalled it.

Complete discussion here: https://github.com/angular/components/issues/18637

0 users liked answer #7dislike answer #70
Ling Vu profile pic
Ling Vu

I imported some classes(FormControl, FormGroup, Validators) which are not modules in app.module.ts
I removed those classes and it solved my problem.

0 users liked answer #8dislike answer #80
tung yu profile pic
tung yu

What worked for me is importing the whole module for MatToolbar.

import {MatToolbarModule} from '@angular/material/toolbar'; 

And then adding MatToolbarModule to the imports[] array in my app.module.ts.

0 users liked answer #9dislike answer #90
NobodySomewhere profile pic
NobodySomewhere

stop your angular service (if you use command prompt or powershell ctrl + c) and run again(ng serve)

0 users liked answer #10dislike answer #100
hamed profile pic
hamed

For me it was due to unused (or rather broken) ValueAccessors – removing them fixed this.

0 users liked answer #11dislike answer #110
Nurseiit A profile pic
Nurseiit A

Copyright © 2022 QueryThreads

All content on Query Threads is licensed under the Creative Commons Attribution-ShareAlike 3.0 license (CC BY-SA 3.0).