Source:  Twitter logo

I'm following this tutorial enter link description here but I'v got stuck at 12:41. I downloaded seed project following link in the video description and issued somman npm install as administrator on Windows 7. But I'm getting following error:

C:\development\angular2\angular2-seed>npm install

> angular2-quickstart@1.0.0 postinstall C:\development\angular2\angular2-seed
> typings install

(I translated following lines to English)
typings is not name of an command, executable or batch.

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.0.0 (node_modules\ch
okidar\node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@
1.0.14: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"
})
npm WARN angular2-quickstart@1.0.0 No description
npm WARN angular2-quickstart@1.0.0 No repository field.
npm ERR! Windows_NT 6.1.7601
npm ERR! argv "C:\\Program Files\\nodejs\\node.exe" "C:\\Users\\Administrator\\A
ppData\\Roaming\\npm\\node_modules\\npm\\bin\\npm-cli.js" "install"
npm ERR! node v4.6.0
npm ERR! npm  v3.10.8
npm ERR! code ELIFECYCLE
npm ERR! angular2-quickstart@1.0.0 postinstall: `typings install`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the angular2-quickstart@1.0.0 postinstall script 'typings ins
tall'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the angular2-quickstart p
ackage,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     typings install
npm ERR! You can get information on how to open an issue for this project with:
npm ERR!     npm bugs angular2-quickstart
npm ERR! Or if that isn't available, you can get their info via:
npm ERR!     npm owner ls angular2-quickstart
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR!     C:\development\angular2\angular2-seed\npm-debug.log

Please advise. Thank you.

EDIT: Attached file npm-debug.log: enter link description here Attached file package.json: enter link description here

Permission Issue. It probably has to do with the path names in windows.

Check the same in Git Bash or Windows Powershell.

You can set the NODE path like : set NODE_PATH=source

Remove the node_modules and run npm install again.

3 users liked answer #0dislike answer #03
Ani profile pic
Ani

If someone is in my situation facing this error and have tried all the solutions mentioned here, and another similar question, like:

  • you are in the right directory

  • you have a package.json file,

  • the JSON is valid,

  • you have tried to run %temp%

  • you have tried " npm install -d --save" etc.

Mine worked by doing "npm install --force"

Note: This was also recommended in the error itself, which I didn't pay attention to earlier.

Even " Yarn install" worked.

0 users liked answer #1dislike answer #10
Singh profile pic
Singh

Copyright © 2022 QueryThreads

All content on Query Threads is licensed under the Creative Commons Attribution-ShareAlike 3.0 license (CC BY-SA 3.0).