Source:  Twitter logo

hi all i used to work on MERN project for sometime but now my react app wont run on localhost:3000. So far i tried the following

  1. Updated node.js/ reinstalled node.js
  2. create new app using npx create-react-app but still localhost:3000 isn't working

I checked if port is opened or not using netstat -aon but localhost:3000 wasn't there. But 0.0.0.0:3000 is there. So my attempt to run telnet 127.0.0.1 3000 was not successful.

Am using windows 10 OS and latest version of nodejs

create .env file at the root of your project and add this line:

PORT = 3000

Then npm start again

3 users liked answer #0dislike answer #03
carrany profile pic
carrany

Try the solution from this topic.

In package.json edit next string from this

"start": "react-scripts start"

to this

"start": "set PORT=3000 && react-scripts start"
2 users liked answer #1dislike answer #12
aopanasenko profile pic
aopanasenko

Finally i found the solution i did installed a package htt-proxy-middleware which actually bugged some files in react, still not sure. but simply you can get back to work by deleting your package-lock.json and entering npm i to reinstall all the packages. It worked for me. I hope it will solve the problem for other developers too.

0 users liked answer #2dislike answer #20
Wasal Rasool profile pic
Wasal Rasool

Copyright © 2022 QueryThreads

All content on Query Threads is licensed under the Creative Commons Attribution-ShareAlike 3.0 license (CC BY-SA 3.0).